Moonlight não é para você, usuário de Ubuntu Lucid !

Um aviso aos colegas, o plugin Moonlight causa diversos problemas no firefox.
Muitos estão fazendo ou já fizeram o upgrade do Ubuntu 9.0x para Ubuntu 10.04 e depois de completarem o upgrade a usabilidade do Firefox não foi das melhores, na realidade o Firefox capota muitas vezes e na tentativa de corrigir o problema, apagam profile, e tentam isso, e tentam aquilo, mas o Firefox continua instável e capotando do nada.

Este problema é causado pelo plugin Moonlight, pacotes para debian e ubuntu estão em repositórios de terceiros e podem ter sido instalados em seu sistema, mas o plugin tem alguma incompatibilidade com o Firefox 3.6.

A solução para este problema é remover estes pacotes :

moonlight-plugin-core moonlight-plugin-mozilla

Poderá usar o Synaptic ou o apt-get na linha de comando.
Estes pacotes não representavam nenhum problema no Ubuntu 9.0x porque o Firefox era uma outra versão, e inclusive eram usados no Ubuntu Script Perfeito naquela versão. Logo que comecei a adaptar o script Ubuntu Perfeito para o Ubuntu 10.04 percebí que algo de ruim acontecia com o Firefox e rastreando o problema cheguei a esse plugin, daí tomei a iniciativa de remover o plugin Moonlight da lista de plugins instalados pelo script.

Se você usou o Script Ubuntu Perfeito e fez upgrade do Ubuntu 9.0x para Ubuntu 10.04 atente-se que provavelmente você estará com essas bibliotecas em seu sistema e pode estar com um Firefox bem instável.

Para quem não fez upgrade nenhum, mas seu Firefox é instável então observe se você tem esse plugin em seu sistema, se sim, então remova-os e estude o comportamento do Firefox dalí em diante.

Anúncios
  1. #1 por Fernando Leme em 7 \07\UTC maio \07\UTC 2010 - 0:24

    Cara, no upgrade do 9.10 pro 10.04 eu percebi uma perda meio acentuada no desempenho.
    Quanto ao firefox, não sei se foi o moonlight, mas depois que eu desinstalei os pacotes que vc indicou ele melhorou razoavelmente de perfomance. Apenas alguns vídeos em flash ficam “engasgando”, o que eu acho estranho no eeepc (teoricamente desenvolvido com foco em internet).

    Enfim, pensei em fazer uma instalação limpa do 10.04 e rodar o seu script em cima dele.

  1. Moonlight no funciona correctamente en Ubuntu Lucid y Firefox 3.6 | Kushelmex.com
%d blogueiros gostam disto: