Instalando o Flash9(plugin e player) no Ubuntu

Como todos devem saber, o formato flash na web já está bem difundido e já começa a aparecer algumas páginas que requerem a versão mais recente do flash desenvolvido pela Adobe. Então vamos mostrar os primeiros passos para instalar o Flash9 tanto o plugin como também o player para Linux. Primeiramente dê um ALT+F2 e execute o comando “gksu gedit /etc/apt/sources.list” e em seguida adicione as seguintes linhas a este arquivo :

deb http://download.tuxfamily.org/3v1deb edgy 3v1n0
deb-src http://download.tuxfamily.org/3v1deb edgy 3v1n0

Este repositório tem pacotes para Ubuntu Edgy, Dapper e Debian unstable, basta voce conferir em http://3v1n0.tuxfamily.org/

Vamos conferir e assinar este repostório :

sudo clear (apenas para treinar o sudo com a senha)
wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add –

Salve e atualize seus repositórios com o comando :

sudo apt-get update

E por fim instale o Flash9 :

sudo apt-get install flashplugin-nonfree flashplayer-nonfree

Pronto! Agora o Flash9 se encontra instalado no seu computado. A versão player(tocador externo) do Flash9 poderá ser encontrado no menu Aplicações->Som e Video. Não encontrei travamentos e nada do tipo e olhe que já estou usando AIGLX com flash9(beta) já a bastante tempo, então recomendo a atualização.

Após a sua instalação eu recomendo remover o repositório “download.tuxfamily.org” que foi acrescentado no /etc/apt/sources.list repetindo novamente o comando ALT+F2 e executando o comando “gksu gedit /etc/apt/sources.list”. Isso porque o repositório contém um monte de outras atualizações que podem ser inconvenientes para voce, mas se voce quiser arriscar com novas atualizações, porém não oficiais então recomendo pelo menos ver a página :

http://3v1n0.tuxfamily.org/dists/edgy/3v1n0/

Para ter uma idéia das atualizações que voce encontrará lá e também novas aplicações que poderiam ser instalados no seu Ubuntu.

Se voce é um daqueles que ficam irritados quando banners em flash saltam na tela impedindo de serem fechadas, então recomendo a instalação dessa extensão chamada FlashBlock para o Firefox :

https://addons.mozilla.org/firefox/433/ 

Anúncios
  1. #1 por Negretti em 18 \18\UTC janeiro \18\UTC 2007 - 12:39

    Olá, obrigado pela dica, mas tenho uma pergunta: o que fazer com o flash antigo?
    Abraço,
    Negretti

  2. #2 por Cristiano Canguçu em 18 \18\UTC janeiro \18\UTC 2007 - 23:29

    MUITO cuidado com o repositório 3v1deb… eu tive um trabalhão pra me livrar de dois pacotes quebrados: no primeiro, do GCstar 1.0, faltaram vários arquivos para o programa rodar. Resolvi instalando primeiro o GCstar 0.5 dos repositórios comuns para depois atualizar.

    O segundo foi um problema… o wpasupplicant do repositório 3v1deb estava TOTALMENTE destruído e eu não consegui mais fazer NADA no synaptic. Haja tempo investido no google.com/linux para descobrir como resolver o problema (o apt-get não quis desinstalar, o cache do apt foi corrompido, um problemão. Acabei resolvendo de forma bastante tosca instalando o .DEB do wpasupplicant do debian unstable por cima).

    Em suma: eu sugiro que só baixem o .deb do flash lá, mas não larguem esse repositório habilitando no dia-a-dia….

  3. #3 por hamacker em 19 \19\UTC janeiro \19\UTC 2007 - 1:09

    Cristiano Canguçu, os pacotes recentes inclusos em 3v1n0.tuxfamily.org são pacotes feitos por terceiros onde os programadores não prestam muita atenção na atualização que eles fazem constantemente.

    Por exemplo, o wpasupplicant do edgy é praticamente perfeito, mas se voce atualizar para wpasupplicant mais recente em 3v1n0.tuxfamily.org também vai atualizar na boa, no entanto quando vier uma proxima atualização, ou seja, atualização da atualização, aí a coisa engrossa.

    O próprio wpasupplicant já foi atualizado 3 vezes dentro do próprio 3v1n0.tuxfamily.org e todas as versões posteriores não atualizam a anterior que vinheram do próprio 3v1n0.tuxfamily.org, entendeu o problema ?

    Não é o pacote vindo de 3v1n0.tuxfamily.org que está ruim, acontece que alguns pacotes simplesmente não atualizam a sí mesmos quando vinheram do mesmo 3v1n0.tuxfamily.org.

    O wpasupplicant é apenas um exemplo, mas que também pode ocorrer com outros pacotes. Solução ? Infelizmente voce foi pela solução mais dificil, mas a solução é ir no Synaptic, localizar o pacote e selecionar e ir até pacote->forçar versão e fazer o downgrade para a versão mais recente do repositório do edgy, feito isso então voce poderá dar um upgrade novamente é pegar a atualização que se encontra no 3v1n0.tuxfamily.org. O Synaptic tem também a opção de prender versão para que nunca aquele pacote sofra atualizações, util apenas para pacotes muito problematicos.

  4. #4 por rafael em 1 \01\UTC fevereiro \01\UTC 2007 - 20:27

    oi eu ainda naumn consegui baixar isso tem alguem pra me ajuda

  5. #5 por Guilherme em 2 \02\UTC março \02\UTC 2007 - 15:54

    Não consegui instalar. Aparece isso:

    Os pacotes a seguir têm dependências desencontradas:
    flashplugin-nonfree: Depende: libc6 (>= 2.4-1) mas 2.3.6-0ubuntu20 está para ser instalado
    Depende: libfreetype6 (>= 2.2) mas 2.1.10-1ubuntu2.2 está para ser instalado
    Depende: libglib2.0-0 (>= 2.12.0) mas 2.10.2-1ubuntu3 está para ser instalado
    Depende: libgtk2.0-0 (>= 2.10.3) mas 2.8.20-0ubuntu1.1 está para ser instalado
    E: Pacotes quebrados

    Poderiam mandar a solução para meu e-mail?

    gmsalomao2@gmail.com

    OBRIGADO!

  6. #6 por cidasouza em 19 \19\UTC março \19\UTC 2010 - 20:38

    vou experimentar depois faço comentário ok

%d blogueiros gostam disto: